Link to a Specific Page in PDF File

Comments

5 comments

  • Avatar
    Thomas Rough (K15t) (Edited )

    Hi Priyanka,

    Thanks for your post.

    Normally when exporting pages that are referenced to via links in the generated PDF, these should automatically direct the reader to the page within the PDF. How did you define the links on your Confluence page?

    Furthermore, which version of our app were you using? If you are not on the latest version would you be able to update as we made some changes to the way links were handled in some recent releases.

    If this issue is occurring on the latest version can you send us an XML export for the affected page tree that you're exporting? To export the content of a single Confluence page, please follow these instructions: https://help.k15t.com/creating-a-xml-export-of-a-single-page-111903666.html.

    You can send this to support@k15t.com. Additionally, it would be great if you could also send the affected generated PDF you received. We can then continue this investigation within the created support case.

    Cheers, Thomas (K15t).

    0
    Comment actions Permalink
  • Avatar
    Peter Bettens (Edited )

    Hello, is there already a solution for this matter?

    I want to create a link from one page in an exported pdf to another page in the same pdf.

    If I use following steps, it generates a link to the page in Confluence and not to the page in the pdf:

    1. In confluence, in the target page, enter /Link and select the source page.
    2. Click Publish.
    3. Export the document with Scroll PDF exporter.

    I assume this is not the correct way to do this?

    0
    Comment actions Permalink
  • Avatar
    Thomas Rough (K15t) (Edited )

    Hi Peter,

    Thanks for reaching out to us. Presumably, you are using Confluence Cloud - was this correct? When inserting a /link to a page that is also included in the export, Scroll PDF Exporter will preserve this linking allowing you to navigate to the specific page in the export when it is clicked.

    Furthermore, if you have the export option Optimize links for print enabled, the link within the generated export will also show the page if refers to (see below):

    If the link is for a page not included in the export, then depending how you have configured how the export handles links in the export options (ie. Enable links to external websites | Enable links to Confluence) will determine if the links are clickable.

    From your description it seems that you have linked a page that is included in the export, but when clicked the link navigates back to the Confluence instance. Was this right? Had you linked to the Space Overview page? If so, this is known issue which you can track here: https://k15t.jira.com/browse/EXP-3003

    If not, could you send an XML export for the affected page tree that you're exporting so that we can investigate this further? To export the content of a single Confluence page, please follow these instructions: https://help.k15t.com/creating-a-xml-export-of-a-single-page-111903666.html.

    Cheers, Thomas (K15t)

    0
    Comment actions Permalink
  • Avatar
    Peter Bettens

    Hi Thomas,

     
    Tx for your reply.
    • Yes, we are using Confluence cloud
    • Yes, I used /link but the link doesn't allow me to link to the page in the export.
    • Yes,  I have linked a page that is included in the export, but when clicked the link navigates back to the Confluence instance.
    • No, I haven't linked to the overview page.
    • I attached the XML export of a page with two different links to different pages in the document.
    • you can find an export in a link
    • I noticed it happened less (but still) when I export a pdf directly from a Confluence page. But it seem to happen always when I export a pdf from a scroll document assembled from pages. 
    • I need this problem solves asap for delivery to our client clients
    • I thought I already dit send you this reply, but didn't notice that it was a no-reply email address- didn't get a warning

    Wkr,

     

    Peter Bettens

     

    0
    Comment actions Permalink
  • Avatar
    Thomas Rough (K15t)

    Hi Peter,

    Thanks for your response. For these public community posts we don't process/attach any attachments that you may attempt to add (sorry should have mentioned in the last post). Therefore, in order to investigate your specific issue can you send the XML exports that highlights this problem to support@k15t.com. This will then create a support case where we can continue the discussion. Cheers, Thomas (K15t)

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk